
Integration Guide
&



                     Table of contents

							       Overview											             1

							       Audience											             2 

							       Why integrate?										            3

							       Before you integrate...									           4

							       Setting up Daylite and Billings for integration						        5

							       Adding a contact or organization from Daylite						        6

							       Importing a project or opportunity from Daylite					       8

							       Sending a project from Daylite to Billings						        9

							       Sending an opportunity from Daylite to Billings				      	 12

							       Sending a task/appointment from Daylite to Billings					     14

							       Opening a project or slip in Daylite							       16

							       Mapping criteria										          17

							       Billing for multiple workers							       	 20

							       Help and other resources						       			   25

							       Index												            26

		



 © 2011 Marketcircle Inc. All rights reserved.

1

Daylite & Billings Integration Guide

Overview

Thank you for downloading Daylite and Billings from Marketcircle. Read this document to learn how Daylite and 

Billings integration enables you to achieve your goals and maximize your business productivity. 

Daylite helps businesses organize themselves with powerful tools such as shared calendars, contacts, tasks, 

projects, notes and more. Billings is the fastest and easiest way to send professional invoices.  As a single-user, 

you can set up your business in Daylite and import data into Billings for tracking time, sending invoices, and 

managing payments. In a multi-user environment, you do all your work in Daylite and import data into Billings 

for sending professional invoices. In this document, you will explore how Daylite & Billings can be used in 

conjunction with each other to help you in taking your business to the next level.

This document will cover the following:

Need for integrationvv

Best practices for getting information from Daylite to Billings vv

Best practices for updating Billings  vv

Sending data back and forth between Daylite & Billings vv

Billing for multiple workersvv
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Audience

This document is intended for Daylite & Billings users who wish to share data between the two applications. The 

primary audience is someone who manages their business in Daylite, but is interested in importing data from 

Daylite to Billings for sending professional invoices and other billing activities.
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Why integrate?

Integration between Daylite and Billings makes it possible to share data between these two powerful 

applications. Consider you have set up your business in Daylite. You have your contacts, organizations, projects, 

opportunities, groups, tasks, appointments, and notes in Daylite. In simple words, all the information about what 

work needs to be done, for whom, by what date, the people involved, the resources, etc are all set up in Daylite. 

At this point, think of the following:

how will you charge a client a certain rate for the work done by you or other team members?vv

how will you send invoices and record received payments?vv

how will you handle a down payment provided by a client to secure your services?vv

what action will you take towards clients who do not pay you in time?vv

This is when Billings comes into picture. Billings helps you manage all the above aspects and many more 

effortlessly, thereby becoming an integral part of your business workflow. 

The seamless integration between Daylite and Billings allows you to add contacts and organizations in Daylite 

as clients in Billings. Any  projects or opportunities linked to the contact in Daylite can be imported as projects 

in Billings. Tasks and appointments linked to these projects become either estimate or working slips in Billings. 

Sending invoices, recording payments, and other billing activities can all be easily accomplished in Billings. 
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Before you integrate...

Some important facts to keep in mind before integrating Daylite and Billings:

 

We recommend that you use the latest version of Daylite and Billings both installed on the same vv

computer. If you’re using an older version of Daylite/Billings and find some incompatibility, please 

contact us at info@marketcircle.com and we’ll assist you. 

You should keep one Daylite and one Billings database open and you can only integrate 		   vv

between the two of them. 

You should be logged in as a user in Daylite.vv
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Setting up Daylite and Billings for integration

In order to get the best out of Daylite & Billings integration, we recommend the following:

It is a good idea to plan and manage your business in Daylite. Thus, all your primary business related vv

information will be in Daylite and you can import it into Billings. For instance, if you create a project 

in Billings, it will only be available in Billings. Whereas, if you create a project in Daylite and import 

into Billings, you have a record of data in both places. 

It is best to start by adding a client in Billings. This makes sure that if you are bringing in a project, vv

opportunity, task, and/or appointment from Daylite, Billings always knows where it is supposed to go. 

It is good to use the Estimate feature of opportunities in Daylite only to set up the line items for the vv

products/services you are selling. You can import these line items into Billings as slips and send them 

to your clients. This makes sure you have the same template styles available for both estimates and 

invoices. 

Backup frequently to keep an updated copy of your database. In case data is lost or damaged, you vv

can restore a backup copy and start working right away.
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Adding a contact or organization from Daylite

Contacts and organizations in Daylite can be added as clients in Billings. 

To add a contact or organization from Daylite

In Billings, choose 1.	 File > Add Client.

In the sheet that opens, choose 2.	 From Daylite in the pop-up menu.

Type a contact or organization name in the search field and press the 3.	 return key to search. 

Select the contact or organization you want to add to Billings.4.	

Click 5.	 Add.
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You can bring in contacts/organizations from Daylite and add them to Billings one at a time. If you already have a 

Billings client who matches the record you want to import from Daylite, Billings alerts you that a duplicate record 

was found. If you still want to proceed, a second client with the same details will be created.

Adding a contact/organization from Daylite
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Importing a project or opportunity from Daylite

Once you add a contact/organization from Daylite as a client in Billings, you can import a linked project/

opportunity from Daylite for the client.

To import a project/opportunity from Daylite for a client

Select a client.1.	

Choose 2.	 File > Import > Import Project Or Opportunity from Daylite for client name. 

	 Billings opens a sheet displaying all the open projects and opportunities.

You can select a project/opportunity you wish to import.vv

If you choose to import an opportunity, you can include line items from the opportunity’s estimate. vv

The taxes you have set up in Billings Preferences can be applied to the estimate.

You can select whether you wish to import appointments, tasks, file references, web references, and/vv

or notes.

You can choose whether you wish to import tasks/appointments as either estimate slips or working vv

slips.

Click 3.	 Import.

If the project/opportunity you import already exists in Billings, then Billings will update it. The update will not 

overwrite your changes.
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Sending a project from Daylite to Billings

Starting from Daylite, you can send a project to Billings. Billings creates a project that retains the same name as 

the project in Daylite. This is an alternate method to bring a project from Daylite into Billings.

For instance, consider you are managing a complex project in Daylite. All the people associated with the 

project are linked to it and assigned different roles. In a multi-user environment, each user has certain tasks and 

appointments to be done in order to complete this project. Let’s assume that you initially send an estimate to 

your client using Daylite to inform them about the cost and time requirements. When your client approves the 

estimate, you and other team members start working on the project. When you finish working,  you can select 

the project and send to Billings as working. The project in Daylite is added to Billings and retains the same name 

as in Daylite. 

The tasks/appointments linked to the project become working slips in Billings. The owner of a task/appointment 

in Daylite becomes a worker in Billings. This is useful to assign the appropriate billing rate for the worker before 

sending an invoice. Select the slips you want to invoice in the Working Slips tab and send an invoice. When you 

receive a payment, you can add it to Billings. Thus, the entire process of managing a complex project becomes 

simple and easy.
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To send a project to Billings starting from Daylite

In Daylite, select a project. 1.	

To send the tasks/appointments linked to the project as working slips, choose 2.	 Actions > Send to Billings 

(Working). OR To send the tasks/appointments linked to the project as estimate slips, choose Actions > 

Send to Billings (Estimate). 

Sending a project from Daylite to Billings
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Note: 

 If the project was not linked to a contact/organization in Daylite, Billings opens a new window where vv

you can select a client to add the project.

If the project was linked to a contact/organization in Daylite who is also a client in Billings, then vv

Billings adds the project to that client.

If the project was linked to a contact/organization in Daylite that is not in Billings, then Billings vv

creates the client and adds the project to that client.

Each time you import a project into Billings, you can filter and view the slips from your last import only. To do 

this, choose View > All Slips and select Last Import from the pop-up menu.

At any point, you can select the project in Billings and update it by choosing File > Update from Daylite. The 

update will not overwrite your changes.
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Sending an opportunity from Daylite to Billings

Opportunities are useful for managing prospects. Starting from Daylite, you can send an opportunity to Billings. 

This is an alternate method to bring an opportunity from Daylite to Billings. You would want to do this if you are 

repeatedly selling certain products or services or you want to send an invoice for a custom product that you have 

set up in Daylite. 

For example, consider you have set up an opportunity in Daylite and linked the associated items (contact, 

organization, etc). You intend to sell certain products with this opportunity, but before you do so, you wish to 

send an estimate. Using Daylite, create line items that specify what product you are selling, pricing information, 

and other details. You can create and send an estimate using Daylite. However, the advantage of using Billings 

for sending estimates is that you can maintain a consistent style for both estimates and invoices. Select the 

opportunity and send to Billings as estimate. Billings creates a new project whose name matches the name of 

the opportunity and links the line items as estimate slips. From a selection of estimate slips, create and send an 

estimate to the client. When the client approves the estimate, you may convert your estimate slips into working 

slips and send an invoice for that amount. Record the payment you receive in Billings and apply it against an 

invoice.

Consider you have to sell a custom product to your client. It is a kind of product that you would be selling once 

in a while. Create an opportunity in Daylite and link the contacts to whom you want to be selling. You can create 

a line item for the custom product that includes the quantity, price, and other information. In this case, you don’t 

want to send an estimate to your client, but you want to send an invoice right away. Select the opportunity and 

send to Billings as working. Billings imports the opportunity and adds it to the list of projects. The line item for 

the custom product becomes a working slip in Billings. Select the working slip and send an invoice to the client. 

When you receive a payment, you can record it in Billings. 
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To send an opportunity to Billings starting from Daylite

In Daylite, select an opportunity. 1.	

To send the tasks/appointments linked to the opportunity as working slips, choose 2.	 Actions > Send to 

Billings (Working). OR To send the tasks/appointments linked to the opportunity as estimate slips, choose 

Actions > Send to Billings (Estimate). 

Note:

If the opportunity was not linked to a contact/organization in Daylite, Billings opens a new window vv

where you can select a client to add the project.

If the opportunity was linked to a contact/organization in Daylite who is also a client in Billings, vv

Billings adds the project to that client.

If the opportunity was linked to a contact/organization in Daylite who is not a client in Billings, then vv

Billings creates the client and adds the opportunity to that client.

Each time you import a project/opportunity into Billings, you can filter and view the slips from your last import 

only. To do this, choose View > All Slips and select Last Import from the pop-up menu.

At any point, you can update the project in Billings by choosing File > Update from Daylite. The update will not 

overwrite your changes.
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Sending a task/appointment from Daylite to 
Billings

You can send tasks and/or appointments from Daylite to Billings as either estimate slips or working slips. Sending 

tasks/appointments to Billings as estimate slips enables you to generate estimates from them and send to clients. 

Sending tasks/appointments to Billings as working slips enables you to generate invoices from them and send to 

clients.

To send a task/appointment to Billings 

In Daylite, select a task/appointment. 1.	

To send the task/appointment as a working slip, choose 2.	 Actions > Send to Billings (Working). OR  To send 

the task/appointment as an estimate slip, choose Actions > Send to Billings (Estimate). 

Note: 

If the task/appointment is not linked to a contact/organization in Daylite, then Billings adds the task/vv

appointment to your “Personal Projects” by creating a project called “Slips Without a Project.”

If the task/appointment was linked to a contact/organization in Daylite that is also a client in Billings, vv

then Billings adds the task/appointment to that client by creating a project called “Slips Without a 

Project.”
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If the task/apppointment was linked to a contact/organization in Daylite that is not in Billings, then vv

Billings creates that client and adds the task/appointment by creating a project called “Slips Without 

a Project.”

Each time you import a task/appointment into Billings, you can filter and view the slips from your last import only. 

To do this, choose View > All Slips and select Last Import from the pop-up menu.

At any point, you can update the project in Billings by choosing File > Update from Daylite. The update will not 

overwrite your changes.

Note: When you import an appointment into Billings from Daylite, the information specified in “Details” section 

of the appointment in Daylite is brought into Billings. This data can be seen in the “Comments” tab of the slip 

window in Billings. Any information in the “Minutes” tab of the Appointment window in Daylite is not imported 

into Billings.

For Repeating Appointments:  For repeating appointments, only the first appointment of the repeating set 

can be sent to Billings. The subsequent repeating appointments (excluding the original appointment) cannot be 

pushed to Billings.  

If you modified (changed the time/name etc.) one of the repeats, you are prompted to apply the changes to 

only that specific appointment, or, to all future appointments belonging to that repeat.  When you select only 

the specific appointment to apply the changes to, that ‘exception’ can then be sent to Billings as they are now 

independent of the repeating appointment.



 © 2011 Marketcircle Inc. All rights reserved.

16

Daylite & Billings Integration Guide

Opening a project or slip in Daylite

For a project, opportunity, task, and/or appointment you’ve imported from Daylite, Billings allows you to open 

that item in Daylite. This is useful if you’re interested in taking a quick look or review that item in Daylite. 

To open a project in Daylite

In Billings, select a project.1.	

Choose 2.	 Project > Open in Daylite.

Billings takes you to the appropriate project/opportunity in Daylite.

To open a slip in Daylite

In Billings, select a slip.1.	

Choose 2.	 Slips > Open Slip in Daylite.

Billings takes you to the appropriate slip in Daylite.
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Mapping criteria

This section explains how different fields are mapped when you do an import from Daylite to Billings. 

Case 1: You add a client from Daylite (File > Add Client) into Billings and import projects, opportunities, tasks, 

and/or appointments for the client. Or, you select a client in Billings and import a project/opportunity from 

Daylite (File > Import > Import Project or Opportunity from Daylite).

Daylite Billings Daylite field Corresponding Billings 

field

Contact Client First name
Last name
Default Organization
Email
Address

First name
Last name
Company
Email
Address

Project (Status must be 
one of New, In Progress, 
Deferred, Cancelled, or 
Abandoned)

Project Name
Started date
Due date
File reference
Web reference

Name
Started date
Due date
Click the “Links” tab to 
see the file and web links.

Opportunity (State must 
be Open)

Project Name
Forecasted Close
File reference
Web reference

Name
Due date
Click the “Links” tab to 
see the file and web links.

Appointment Estimate/working slip Name
Owner
Start date
End date
Duration
Details

Name
Worker
Started date
Completed date
Duration
Comments
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Daylite Billings Daylite field Corresponding Billings 

field

Task Estimate/working slip Name
Owner
Due date
Details

Name
Worker
Due date
Comments

File reference File

Web reference Web URL

Line item from 

opportunity’s estimate

Estimate/working slip Name
Quantity
Price

Name
Quantity
Price

Note:

1. A project in Daylite that is not marked as Completed can be imported into Billings using the method given 

above. If you choose to import linked tasks/appointments as estimate slips, then in Billings, the project state is 

set as Estimate. Otherwise, it’ll be set as Active. 

2. An opportunity in Daylite whose state is Open can be imported into Billings. If you  choose to import linked 

tasks/appointments as estimate slips, then in Billings, the  project state is set as Estimate. Otherwise, it’ll be set 

as Active. 

3. For tasks marked as Done in Daylite, the start and end time is recorded as Duration for the slip in Billings.
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Case 2: Starting from Daylite, you select a project/opportunity/task/appointment and send it to Billings (Actions 

> Send to Billings). 

Daylite Billings Daylite field Corresponding Billings 

field

Contact Client First name
Last name
Default Organization
Email

First name
Last name
Company
Email

Project Project Name
Status
Due date
Started date
Completed date
Extra fields 1-4

Name
State
Due date
Started date
Completed date
Extra fields 1-4

Opportunity Project Name
State
Forecasted Close
Actual Close
Extra fields 1-4

Name
State
Due date
Completed date
Extra fields 1-4

Appointment Estimate/working slip Name
Category
Owner
Start date
End date
Duration
Details

Name
Category
Worker
Started date
Completed date
Duration
Comments

Task Estimate/working slip Name
Category
Owner
Due date
Start date
End date
Duration
Details

Name
Category
Worker
Due date
Started date
Completed date
Duration
Comments

Line item from 

opportunity’s estimate

Estimate/working slip Name
Quantity
Price
Discount
Total

Name
Quantity
Price
Discount
Total
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Billing for multiple workers

Consider a company is using projects in Daylite for grouping work. In a multi-user environment, there are many 

users who are working on a project. Also, there are many projects in the project list with different users linked to 

each one of them. Each user who is working on the project creates an appointment, assigns a category, enters all 

the details, and links the appointment to the project. When it is the time to send an invoice to the client (usually, 

this is at the end of the month),  the Billings administrator brings the project data from Daylite to Billings. If the 

project is already there in Billings, then the Billings administrator can update the project in Billings to ensure that 

it has the latest information. 

Each worker contributing to the project maybe charged different hourly rates. The Billings administrator gets 

all the appointments linked to the project as slips in Billings. To accurately identify who has worked on each slip, 

Billings allows you to set up workers and enable labeling slips with workers. 

Workers are the people for whom you bill time. Generally, a slip corresponds to a task or a series of tasks; a 

worker corresponds to who actually performed those tasks. For more information about workers, choose Help > 

Billings Help and search for workers.



 © 2011 Marketcircle Inc. All rights reserved.

21

Daylite & Billings Integration Guide

To add workers in Billings

Choose 1.	 Billings > Preferences.

Click2.	  Labels.

Click the 3.	 Workers tab.

Select the 4.	 Enable labeling slips with workers checkbox. 

Click the + button and enter the name of a worker. Please make sure that the worker names exactly match 5.	

the names of the workers in other systems such as Daylite.

To assign a worker to a slip

To assign a worker for a slip, open the slip by double-clicking and select a worker of your choice. 

When you import a task/appointment from Daylite, the owner of the task/appointment in Daylite becomes a 

worker in Billings and is automatically added to the list of workers. The worker name exactly matches the full 

name of the owner in Daylite. If you are adding a worker manually in the Preferences, the name of the worker in 

Billings should exactly match the owner name of the task/appointment in Daylite.

To show the worker column

Working from the Estimate Slips tab or Working Slips tab, right-click the column header and select Worker.
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Setting rates

You can apply rates to slips on a per worker basis. If you have multiple slips of a worker, then you can bulk edit 

the slips to apply a rate to all the slips at once. 

To edit a slip for applying a rate

Open a slip by double-clicking.1.	

Enter a rate.2.	

Click 3.	 OK.

To bulk edit multiple slips for applying a rate 

Select the slips.1.	

Choose 2.	 File > Edit Slips. 

     The Multiple Slip Information window opens.

Select the 3.	 Rate checkbox. Enter a rate that has been fixed for the worker.

When you are done, click 4.	 OK.

    Billings applies the rate you specify to all the slips you have selected.

Enter any other information into the slips as needed. When you are done, select the slips you wish to invoice and 

create an invoice for sending to the client. 

If a worker wants to expense a certain amount, then the Billings administrator should manually create an 

expense slip, specify all the details, and invoice it to the client. 
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Workflow for a worker

Step 1: Enter time in Daylite by creating appointments and tasks.

Step 2: Link the appointments and tasks to the same project that was imported into Billings.

Workflow for a Billings administrator

a. Client and project don’t exist in Billings

Step 1: Add the client from Daylite into Billings.

Step 2: Import the project/opportunity from Daylite to Billings. Bring the tasks and appointments 			 

	 associated with the project/opportunity as estimate or working slips.

	 Billings creates a new project whose name matches the name of the project/opportunity in Daylite. 		

	 All tasks/appointments in Daylite are imported as estimate or working slips based on your selection.

Step 3: To view the slips from the last import in Billings, choose View > All Slips and select Last Import 		

	 from the pop-up menu. Note that the owner of a task/appointment in Daylite becomes a worker 		

	 in Billings and is automatically added to the list of workers. The worker name matches the full name 		

	 of the user in Daylite.

Step 4: Open the slips, enter the appropriate information, and send the invoice.



 © 2011 Marketcircle Inc. All rights reserved.

24

Daylite & Billings Integration Guide

b. Client and project exist in Billings

Step 1: In Billings, choose File > Update from Daylite.

Step 2: To view the slips from the last import in Billings, choose View > All Slips and select Last Import 		

	  from the pop-up menu. Note that the owner of a task/appointment in Daylite becomes a worker in 		

 	 Billings and is automatically added to the list of workers. The worker name matches the full name 		

 	 of the user in Daylite.

Step 3: Open the slips, enter the appropriate information, and send the invoice.

How do I show the worker name on an invoice?

When you are sending an invoice, do the following:

In the Invoice window, click the 1.	 Preview tab.

Click 2.	 Options.

Select the 3.	 Show worker name checkbox.

Click 4.	 OK.
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Help and other resources

There are a number of resources available to help you to learn more about Daylite and Billings integration, 

and provide answers when you have technical questions. 

We have certified partners who can provide product training and other specialized services. For vv

more information, please visit http://partners.marketcircle.com/partners/index.

Apple Help offers step-by-step instructions and tips for making the most of Billings. While vv using 

Billings, choose Help > Billings Help. 

The Billings support website and Knowledge Base has up-to-date articles that can help you vv solve 

technical difficulties. Visit www.billings3.com/support. 

The Billings Forums are user-to-user forums, where you can share ideas, tips, and questions vv with 

fellow Billings users. Marketcircle engineers, designers, and support staff also share their knowledge 

on the Billings forums. Visit http://forums.marketcircle.com.
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